
The Gelsim Program

Gelsim is a program which simulates the process of producing a restriction map of a DNA
molecule.  Using this program you will cut the DNA, run gels, measure fragments, and piece
together a map showing where the restriction enzymes cut.

Starting the exercise

You activate the program by double-clicking on the Gelsim icon, or alternatively by clicking once
on the icon and choosing Open from the File menu.  After the introductory screen, the computer
will show a dialog box asking you to input your name, which will look something like the
following:

For the moment you should just type your name, which may be in any format, and click the
mouse button while the pointer is on the OK button.  This button is highlighted, which means
that pressing the Return or Enter keys will have the same effect as clicking on the button.

The program begins by converting the name into a number.  This number will be shown in a
second dialog box, and it is important that you note down this number during this time.  It is this
number which is used to generate the sequence you will be working on.  If you need to regenerate
the sequence at a later stage, you should use this number to re-start the exercise, rather than the
name.  Also if you hand in a report for the exercise, the number will be required to check the
restriction map which you obtain.
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The menus

The selection of menus in the program is as follows:

File         Edit      Workbench        Photos         Help

Most of the commands needed for this program are in the Workbench menu.  Commands in this
menu are grouped in four headings as shown below:

    (1)                    (2)                       (3)                                        (4)
Pour a gel      Cut DNA               Run the gel                       Throw out gel
                      Size markers       Activate gel cutter
                      Pick gel slot        Cut out fragment
                      Load DNA
                      Throw away DNA

All operations with photographs (see below) are handled by the Photos menu.  Other commands
which are are available at all times are contained within the File and Help menus.  The Edit menu
is inactivated and is only included for compatibility with Macintosh standards.

Getting started on the project

Initially, when you have started the program and entered your name, you will be confronted by a
blank screen, with no clues about what you are to do.  The only thing which you can do is to scan
the different menus, particularly the Workbench menu which is the main working menu.  Doing
this, you will find that the only command which is highlighted on the Workbench menu is the
first command, Pour a gel.  Nothing else works until you do this.

This scanning of the menus illustrates an important point about the way that the program works.
At each stage, there will be one or more actions which are appropriate.  These appropriate
options are activated, ie. not dimmed, in the menus.  The first thing which needs to be done is the
pouring of a gel.  Once you have done this, you will find that other commands become enabled
and therefore available.

Some menu options are available at all, or nearly all, times.  For example, the options of quitting
(File menu) or throwing away the gel (Workbench menu) are available at most times.  The items
on the Help menu are similarly available at all times.

Digesting DNA

In real life, the cutting of DNA by restriction enzymes takes a considerable amount of time.  You
would normally run several digests at the same time.  While these digestions are running, you
might pour a gel.  It would certainly not be efficient to wait until one reaction has finished before
beginning the next.
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This computer program works in a slightly different way.  For simplicity, it is assumed that
cutting of a DNA sequence and loading it onto a gel are operations which occur sequentially.
Once one sequence has been cut and loaded, you then start on the next.

Having poured a gel, you will now see that the Cut DNA and the Size markers commands are
activated.  If you activate the  Cut DNA item, you will see the dialog box shown below.

You don't have to do anything except click on the restriction enzyme with which you wish to
digest the DNA.  You are limited to cutting with either one or two enzymes, or you may choose
not to cut at all.

If you click on one of the enzymes, the Complete / Partial digest choice will be activated.
Partial digests in this case are guaranteed to produce not just the fragments between adjacent
markers, but all combinations of fragments between each cutting site.

Once DNA has been cut or size markers selected, a pipette containing the cut DNA will appear,
and the Pick gel slot command is activated:
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You need to move the mouse button over the pipette, and drag the pipette so that the tip is over a
vacant slot.  The Pick gel slot command does not actually do anything except tell you what to
do.  You can use the cursor keys (up, down, left, right) for fine control.

If the tip is over a vacant slot, the Load DNA command will be activated.  Use this command to
put the DNA into the gel slot and dispose of the pipette.  The Enter or Return keys will also
have the same effect at this stage.  Alternatively, if you have changed your mind and decided not
to use that sample, move the pipette off the gel and activate the Throw away DNA command
(not recommended in real life).

Marker DNA

As an alternative to cutting the unknown DNA, you may run samples of marker DNA of known
sizes.  Three markers are available as follows:

   8510
   7350
   6110
   4840
   3540
   2810
   1950
   1800
   1510
   1390
   1160
     980
     720
     480
     360

SPP1/EcoRI

 23700
   9416
   6557
   4361
   2322
   2027
     564
     125
 

λ/HindIII

 21800
   7520
   5930
   5540
   4800
   3410

/EcoRIλ
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Running the gel

Once DNA samples have been loaded into one or more lanes, running the gel becomes an option.
Accessing this option on the menu will bring up the following dialog box.  If you click the OK
button, the gel will run at the standard times of 60 minutes at 100 volts.  You can, if you wish,
change either of these values.  As standard scroll bars, you can change values in any of three
ways: (a) clicking in the arrows, which gives the finest control, (b) clicking in the scroll bar to the
left or right of the movable box, (c) dragging the box.  Clicking in the OK button then confirms
any changes you have made.  Clicking the Cancel button, as in most cases, dismisses the dialog
box without any action taken.
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Get info

You will find a descrption of the current gel from the Get info command.  The diagram below
shows one example of such a window:

The top radio buttons show the current status of the gel.  In this case the gel is loading and not
yet run, with seven tracks, the last one currently empty.  The first track has size markers.  The
remaining tracks are loaded with the unknown DNA, uncut in the second track, digested with
either one or two enzymes, including a partial digest in track 6.  The right-most column shows the
user name and number, the number of the gel currently being run, and the Cancel button to
dismiss the window.  The Show size markers button brings up a window with the list of size
markers shown previously.
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Taking photographs

If you run a gel, you may see something like the following:

There are various bands, whose length you will probably need to measure.  This is best done by
taking a photograph, which preserves the results for later reference and allows the bands to be
better visualised.  Choose the Take a photo item on the Photos menu.  An alert box will tell you
that a photograph has been taken.  Click anywhere to make this box go away.  From this point
onwards, you may look at the photograph at any stage using the Retrieve photo item.  In the
present case, the photo would look as shown on the following page.

Bands can be measured using the ruler, which can be moved anywhere over the photo.  Use the
cursor keys for fine control.

While a photo is shown on the screen, only the Put away photo item is active.  Nothing else can
be done until the photo is put away.  The last item on the Photos menu, Throw out photo, will
only become active if the maximum number of stored photographs (20) is exceeded.

Cutting out fragments

The small object above and to the left of the gel is the gel cutter.  Move it over any fragment you
wish to cut from the gel, and access the Cut out fragment command.  A dialog box will appear
showing the number associated with that fragment.  For example, the gel above is Gel 1
(numbered in the bottom right corner), and the first fragment cut from this gel would be assigned
the label 1.1.  You need to exercise care in noting down where these fragments come from.
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If you have cut out fragments from a gel, the program recognises this when you come to run the
next gel (after you have thrown out the old gel) by changing the form of the dialog box to allow
you to choose from the available fragments.  In the above case, you would get a dialog box as
shown below:
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As well as choosing the restriction enzyme(s) and Complete / Partial, you can also nominate the
DNA in this case.  The original unknown DNA is chosen by default.  There is only enough DNA
in each sample for two tracks.  Once you have used up the fragment, the following boxes will
show this item as dimmed.

Samples may be cumulated from one gel to the next.  However there is only room to store 20
samples, so that if you reach this limit you will have to start using some before others can be
added.

Tutorial

A tutorial may be available, giving examples of some aspects of restriction enzyme mapping.
Access this from the second group of the Help menu.  As with the Help screens, you can go back
and forwards through the tutorial, and must quit the tutorial before doing anything else.  Unlike
the Help screens, you can only start the tutorial at the beginning.

Trial run

The program gives you considerable flexibility in running trial examples.  You can run these at any
stage, but must interrupt any work done on the unknown sequence, since the program can only
hold one sequence at a time.

When you access Trial  from the Help menu, you will see a similar blank screen to that shown
when the program first starts, except that there is an extra menu called Answers.  The last item in
this menu, Show map, is what you use to show the true map.  The trial item has also changed to
End trial, and there is a new item called New sequence at the bottom of the help menu.

Naturally you will get more out of the trial as a practice if you try to work out the map before
looking at the answers.  However there is nothing to stop you looking at answers at any time
while in trial mode, and you can always call on another sequence if you have looked at one.

When you access Show map, a menu will appear which allows you to nominate which enzymes
are to be shown in the map.  A single check box also gives you the opportunity of nominating all
enzyme sites.  The map which is produced may, however, be a little difficult to interpret if there
are many enzyme sites close to each other.

The menu also gives you the choice of nominating one of the enzmes as the apex (12 o'clock) of
the map.  This only takes effect if the map is circular.  If you have already drawn a map using one
such enzyme as the apex then it makes sense to choose this to check on your map.

Once the map is showing on the screen, many other options become available on the answers
menu.  The map can be reversed, either for a circular or linear map, using the Flip item.  If you
have a circular sequence, the map can also be rotated to use other occurrences of the nominated
enzyme at the apex.
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The map can be printed out.  Just use the Print command from the answers menu.  It can be
saved to a file in two different ways.  The first way is as a picture (PICT) file, which can be
accessed from many drawing or word-processing programs.  The second way is as a text file
(TEXT), in which the map positions and distances are listed out sequentially.  This type of file
can be read and/or altered from most word-processing programs.

While the map is shown on the screen, most other items in the program are inactivated.  You will
see that the bottom item in the Answers menu has now become Hide map, and you must do this
before going back to do anything else.

In order to get back to try the unknown sequence, you will eventually have to access the End
trial menu item, which is itself inactivated while a map is shown on the screen.  Alternatively
you can quit from the File menu, and re-start the program.

Some rules and restrictions of the program

Nothing can be done unless a gel has been poured.  The number of tracks on a gel may be from 4
to 7.  Only one gel may be run at a time, so that the old gel must be thrown away before a new
one can be poured.

The migration distance of fragments on the gel may be controlled either by changing the time of
run or the voltage.  Replicate runs of the same time and voltage run at exactly the same rates, so
that the gel will only need to be calibrated once.  The distance migrated on the gel follows a log-
linear relationship with size, except for the very large lambda molecules.  Circular molecules may
run either a little slower or faster than the equivalent sized linear molecule.

Photographs may only be taken immediately after a gel has been run.    Photographs may be
retrieved for measurement at any stage, although only one photograph may be shown on the
screen at a time.  A total of 20 photographs may be stored at any one time.  When this limit is
reached, a dialog box will ask you to remove old photos before new ones can be added.
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